Курс валют на 15 октября
$ USD 64.3652 ▲+0.1415
€ EUR 70.9305 ▲+0.2009

Обновление зависимостей

Обновление зависимостей

Composer создает файл

composer.lock
который хранит точную версию каждого пакета, который он загрузил во время первого запуска
php composer.phar install
. Если вы поделились проектом с другими разработчиками и файл
composer.lock
является частью него, то при запуске
php composer.phar install
они получат ту же версию, что и вы. Чтобы обновить ваши зависимости запустите
php composer.phar update
.

Очень удобно гибко указывать требуемые версии. Если вы нуждаетесь в версии ~1.8, что значит “всё что новее 1.8.0, но меньше 2.0.x-dev”. Вы также можете использовать шаблон

*
, например
1.8.*
. Теперь команда Composer
php composer.phar update
обновит все ваши зависимости до новейших версий, которые соответствуют указанным ограничениям.

RSS
Нет комментариев. Ваш будет первым!
Загрузка...

Лучшие статьи раздела